- - - By CrazyStat - - -

CMSimple_XH (1.5.X) Bedienungsanleitung (Archiviert!)



(Version 1.0.4 vom 08.11.2014)

Sie sind hier: jquery

3.1.5.2 • • • jquery

Unter "Plugins" => "jquery" kann eine kleine Startoberfläche der freien und umfangreichen JavaScript-Bibliothek aufgerufen werden, von der CMSimple_XH einige Funktionalitäten nutzt.
Von dieser Startseite des Plugins jquery haben Entwickler und Webmaster die Möglichkeit die Systemparameter unter "Konfiguration" zu ändern.

Konfigurationsseite:

autoload Hier wird die Handhabung der JS Bibliotheken konfiguriert.
autoload: wird eine "1" hier eingetragen, dann werden alle JS Bibliotheken geladen und sind permanent verfügbar
Defaulteinstellung: leer
file Hier werden die Systemdateien und deren Formatierung hinterlegt.
file core: Defaulteinstellung (bis CMSimple_XH 1.5.7): jquery-1.8.3.min.js
Defaulteinstellung (ab CMSimple_XH 1.5.8): jquery-1.9.1.min.js
file css: Defaulteinstellung (bis CMSimple_XH 1.5.7): smoothness/jquery-ui-1.9.2.min.css
Defaulteinstellung (ab CMSimple_XH 1.5.8): smoothness/jquery-ui-1.10.2.min.css
file migrate:
(ab CMSimple _XH 1.5.8)
Defaulteinstellung: jquery-migrate-1.1.1.min.js
file ui: Defaulteinstellung (bis CMSimple_XH 1.5.7): jquery-ui-1.9.2.min.js
Defaulteinstellung (ab CMSimple_XH 1.5.8): jquery-ui-1.10.2.min.js
utf8-marker (bis CMSimple_XH 1.5.7)
utf8-marker: Defaulteinstellung: äöüß
version Hier sind die verwendeten jquery Versionen hinterlegt.
version core: Defaulteinstellung (bis CMSimple_XH 1.5.7): 1.8.3
Defaulteinstellung (ab CMSimple_XH 1.5.8): unused / deprecated
version ui: Defaulteinstellung (bis CMSimple_XH 1.5.7): 1.9.2
Defaulteinstellung (ab CMSimple_XH 1.5.8): unused / deprecated

Sprachseite:

cf  
cf autoload: Defaulteinstellung: Setzen Sie dies auf <b>1</b> und die JS Bibliotheken sind permanent verfügbar.
utf-8-marker  
utf8-marker: Defaulteinstellung: äöüß


Mit der Veröffentlichung von CMSimple_XH 1.5.10 wird "jQuery for CMSimple" in der Version 1.5.1 vom 07.02.2014 ausgeliefert, welches die jQuery Version 1.11.0 & Migrate-Plugin und jQueryUI Version 1.10.4 enthält.

Unter CMSimple_XH 1.5.10 sehen die jQuery-Konfigurationsmöglichkeiten wie folgt aus:

Konfigurationsseite:

autoload Hier wird die Handhabung der JS Bibliotheken konfiguriert.
autoload: wird eine "1" hier eingetragen, dann werden alle JS Bibliotheken geladen und sind permanent verfügbar
Defaulteinstellung: leer
load  
load migrate: ob das migrate-Plugin geladen wird oder nicht
Defaulteinstellung: true
version Hier sind die verwendeten jquery Versionen hinterlegt.
version core: Defaulteinstellung (CMSimple_XH 1.5.10): 1.11.0
version migrate: Defaulteinstellung (CMSimple_XH 1.5.10): jquery-migrate-1.2.1.min.js
• version ui: Defaulteinstellung (CMSimple_XH 1.5.10): 1.10.4

Sprachseite:

cf  
cf autoload: Defaulteinstellung (CMSimple_XH 1.5.10): Setzen Sie dies auf <b>1</b> und die JS Bibliotheken sind permanent verfügbar.
cf load migrate: Defaulteinstellung (CMSimple_XH 1.5.10): Whether to load the Migrate-plugin or not.
utf-8-marker  
utf8-marker: Defaulteinstellung (CMSimple_XH 1.5.10): äöüß

In allen Versionen wird im Menüpunkt "Hilfe" eine separate Hilfeseite vom Entwickler des Plugins für Entwickler und Webmaster angezeigt.